aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2014-02-14 16:24:27 +0000
committerLinaro Code Review <review@review.linaro.org>2014-02-14 16:24:27 +0000
commit818a10190a0643a56b6b294632478a15e09e50f2 (patch)
tree6d0977005e9ea4d62f0edc8da007f334918c51bd
parent45825a2d9aed6e5184dc559d198c17f580af56ff (diff)
parent762324afd8b964ba2cf5904a0a6b28ca95431a16 (diff)
Merge "lng-network-config: new package with LNG config"
-rw-r--r--meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules43
-rw-r--r--meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb11
2 files changed, 54 insertions, 0 deletions
diff --git a/meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules b/meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules
new file mode 100644
index 00000000..5a8be418
--- /dev/null
+++ b/meta-linaro/recipes-extra/lng-network-config/files/70-persistent-net.rules
@@ -0,0 +1,43 @@
+# lng-amarillo-01
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="66:06:3e:f9:4f:ae",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-arndale-01
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:8e:8f:32:21:98",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-arndale-02
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:8c:cc:92:21:98",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-arndale-03
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:f4:0c:d6:16:33",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-arndale-04
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:8f:4f:09:5e:44",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-arndale-05
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="02:b6:8d:b5:c7:24",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-generator-01
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="d8:9d:67:26:ae:e8",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-generator-02
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="d8:9d:67:26:cd:d8",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-keystone-01
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c4:ed:ba:99:f4:09",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-keystone-02
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c4:ed:ba:9a:8c:47",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
+
+# lng-keystone-03
+SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="c4:ed:ba:9a:67:60",
+ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"
diff --git a/meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb b/meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb
new file mode 100644
index 00000000..2987b040
--- /dev/null
+++ b/meta-linaro/recipes-extra/lng-network-config/lng-network-config_0.1.bb
@@ -0,0 +1,11 @@
+SUMMARY = "This package contains LNG specific configuration"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+RDEPENDS_${PN} = "udev"
+
+SRC_URI = "file://70-persistent-net.rules"
+
+do_install() {
+ install -D -p -m644 ${WORKDIR}/70-persistent-net.rules ${D}/etc/udev/rules.d/70-persistent-net.rules
+}