aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org>2017-10-05 03:19:17 +0300
committerMaxim Uvarov <maxim.uvarov@linaro.org>2017-10-16 21:50:18 +0300
commitff51f6363c9fad843f7872ad8048740d10368dd1 (patch)
treec84c02ac6adfd363650bf88496c32b9a785b3030 /Makefile.am
parent6a119c79b59de3c8ee9e51f3ceba9d26f24c3ce4 (diff)
test: linux-gen: move platform-specific tests to platform directory
Signed-off-by: Dmitry Eremin-Solenikov <dmitry.ereminsolenikov@linaro.org> Reviewed-by: Bill Fischofer <bill.fischofer@linaro.org> Signed-off-by: Maxim Uvarov <maxim.uvarov@linaro.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c43679e7..c8013c2c8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,13 +3,18 @@ AM_DISTCHECK_CONFIGURE_FLAGS = --enable-user-guides \
--enable-helper-linux \
--with-testdir
-#@with_platform@ works alone in subdir but not as part of a path???
-SUBDIRS = @platform_with_platform@ \
+if PLATFORM_IS_LINUX_GENERIC
+PLATFORM_DIR = platform/linux-generic
+PLATFORM_TEST_DIR = platform/linux-generic/test
+endif
+
+SUBDIRS = $(PLATFORM_DIR) \
helper \
helper/test \
doc \
example . \
- test
+ test \
+ $(PLATFORM_TEST_DIR)
@DX_RULES@