aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve McIntyre <steve.mcintyre@linaro.org>2016-03-24 17:50:51 +0000
committerSteve McIntyre <steve.mcintyre@linaro.org>2016-03-24 17:50:51 +0000
commit1588745a5367d6e59d2d0a1e14193fcb3cb7be99 (patch)
tree0788363bdbc5d71042f76fc23f1b95d167bf7645
parentc03d68da5431390e2f83bdc1c1e45f09e5cd3910 (diff)
Initial Debian packagingdebian
Change-Id: I4190095771711f22de5d248a11eb0697ad9d527a
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control33
-rw-r--r--debian/copyright24
-rwxr-xr-xdebian/rules32
5 files changed, 95 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..d1f3eb8
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+vland (0.6-1) UNRELEASED; urgency=medium
+
+ * Initial upload.
+
+ -- Steve McIntyre <93sam@debian.org> Thu, 24 Mar 2016 17:41:52 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..414a18e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,33 @@
+Source: vland
+Section: net
+Priority: extra
+Maintainer: Steve McIntyre <93sam@debian.org>
+Standards-Version: 3.9.6
+X-Python-Version: 2.7
+Build-Depends: debhelper (>= 9.0.0), dh-python,
+ python | python-all | python-dev | python-all-dev,
+ python-setuptools (>= 3)
+Homepage: http://www.linaro.org/projects/test-validation/
+
+Package: vland
+Architecture: all
+Depends: postgresql, postgresql-client, postgresql-common, ${python:Depends}, ${misc:Depends}
+Recommends: fonts-inconsolata
+Description: VLAN management daemon
+ VLANd is a python program intended to make it easy to manage
+ port-based VLAN setups across multiple switches in a network. It is
+ designed to be vendor-agnostic, with a clean pluggable driver API to
+ allow for a wide range of different switches to be controlled
+ together.
+ .
+ Various of the switch vendors have management applications available
+ which should be able to do a similar job, but they're typically not
+ scriptable, or locked to only control their own vendor's
+ equipment. VLANd is designed (and hoped!) to be better. We've found
+ that other network management programs also exist, but either they
+ don't manage VLANs in the way we want or they depend on large
+ frameworks like Openstack.
+ .
+ VLANd is designed to augment Linaro's LAVA hardware and software
+ testing infrastructure, but is hoped also to be useful as a standalone
+ tool.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..ca8e633
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,24 @@
+Format: http://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: VLANd
+Source: https://git.linaro.org/lava/vland.git
+
+Files: *
+Copyright: Copyright 2014-2016 Linaro Limited
+License: GPL-2+
+ This program is free software; you can redistribute it and/or modify it
+ under the terms of the GNU General Public License as published by the
+ Free Software Foundation; either version 2, or (at your option) any
+ later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software
+ Foundation, 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301,
+ USA.
+ .
+ On Debian GNU/Linux systems, the complete text of the GNU General
+ Public License can be found in `/usr/share/common-licenses/GPL-2'.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..1842f50
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,32 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+#
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+#
+# Modified to make a template file for a multi-binary package with separated
+# build-arch and build-indep targets by Bill Allombert 2001
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+PYTHON2:=$(shell pyversions -r)
+install_dir=$(call py_libdir, $(PYTHON2))
+
+%:
+ dh $@ --with python2
+
+override_dh_auto_build:
+ dh_auto_build
+ python setup.py build
+
+# get upstream version for get-orig-source target
+VERSION:= $(shell dpkg-parsechangelog | grep '^Version: ' | sed -e 's/^Version: //' | sed -e 's/\-.*$$//')
+
+sdist-orig:
+ python setup.py sdist
+ mv -v dist/vland-*.tar.gz ../vland_$(VERSION).orig.tar.gz
+ $(RM) -r versiontools-*.egg/