summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/changelog54
1 files changed, 54 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 4593a40..d690e43 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,57 @@
+qrtr (0.0+1g539c83d-1) buster; urgency=medium
+
+ [ Bjorn Andersson ]
+ * qrtr-cfg: Add to .gitignore
+ * qrtr-lookup: Make output easier to read
+ * qrtr: ns: Don't broadcast reset command
+ * qrtr: Hide build warning
+ * ns: Track services per node
+ * ns: Extract NS message handling into separate functions
+ * ns: Refactore control message handling
+ * ns: Store local node id in context
+ * ns: Add static bcast_sq to context
+ * make: Link non-static
+ * ns: Advertise new and removed services
+ * ns: Cleanup debug and error prints
+ * ns: Move qrtr_ctrl_cmd struct to ns.h
+ * lib: Provide new API for clients to register services
+ * ns: Implement DEL_CLIENT
+ * ns: Make del_client always propagate del_client
+ * ns: Handle BYE control message
+ * lib: Replace qrtr_publish() and qrtr_bye() implementations
+ * ns: Introduce lookup registration
+ * lookup: Transition to using control port
+ * ns: Remove the ns service
+ * ns: Rename context socket
+ * ns: Cleanup socket creation
+ * cfg: Request and check return value
+ * lib: Add helpers for handling control messages
+ * ns: Replace lookup result with new and del server messages
+ * lib: Fix endian handling and add new/del server
+ * lookup: Report service, version and instance separate
+ * lookup: Extend service name table
+ * qrtr-ns: Propagate the node in BYE
+ * libqrtr: Don't require socket to be bound for lookup
+ * qrtr-ns: Move DEL_SERVER logic to server_del
+ * qrtr-ns: Sanity check origin of messages
+ * lookup: Add DIAG service
+ * libqrtr: Don't enforce server port to be bound
+ * qrtr: Backport future qrtr.h uapi
+ * libqrtr: Add qrtr_decode() operation
+ * qrtr: Drop container.h
+ * qmi: Introduce QMI encoder/decoder helpers
+ * libqrtr: Rename libqrtr.c for the purpose of symmetry
+ * libqrtr: Remove depricated functions
+ * Makefile: Add lib to include path of qrtr-cfg
+
+ [ Ben Chan ]
+ * libqrtr: define AF_QIPCRTR if it isn't defined in libc header
+
+ [ Nicolas Dechesne ]
+ * qrtr.service: ensure qrtr modules are loaded
+
+ -- Nicolas Dechesne <nicolas.dechesne@linaro.org> Wed, 18 Apr 2018 13:58:27 +0200
+
qrtr (0.0+0+9c85f35a-1) stretch; urgency=medium
* Makefile: add standard GNU makefiles directory variables