aboutsummaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMarcin Kuzminski <none@none>2010-02-18 13:01:57 +0100
committerMarcin Kuzminski <none@none>2010-02-18 13:01:57 +0100
commitee2f692ce7af625e890a335a2ba8d7d908522a2c (patch)
treea4c8e1f6ae070067245be067c1bcf675adfb2ffa /setup.py
initial commit.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py38
1 files changed, 38 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 00000000..da3a301b
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,38 @@
+try:
+ from setuptools import setup, find_packages
+except ImportError:
+ from ez_setup import use_setuptools
+ use_setuptools()
+ from setuptools import setup, find_packages
+
+setup(
+ name = 'pylons_app',
+ version = '1.0',
+ description = '',
+ author = 'marcin kuzminski',
+ author_email = 'marcin@python-blog.com',
+ url = '',
+ install_requires = [
+ "Pylons>=0.9.7,<=0.9.7.99",
+ "SQLAlchemy>=0.5,<=0.5.99",
+ "Mako>=0.2.2,<=0.2.99",
+ ],
+ setup_requires = ["PasteScript>=1.6.3"],
+ packages = find_packages(exclude = ['ez_setup']),
+ include_package_data = True,
+ test_suite = 'nose.collector',
+ package_data = {'pylons_app': ['i18n/*/LC_MESSAGES/*.mo']},
+ message_extractors = {'pylons_app': [
+ ('**.py', 'python', None),
+ ('templates/**.mako', 'mako', {'input_encoding': 'utf-8'}),
+ ('public/**', 'ignore', None)]},
+ zip_safe = False,
+ paster_plugins = ['PasteScript', 'Pylons'],
+ entry_points = """
+ [paste.app_factory]
+ main = pylons_app.config.middleware:make_app
+
+ [paste.app_install]
+ main = pylons.util:PylonsInstaller
+ """,
+)