aboutsummaryrefslogtreecommitdiff
path: root/tools/gator/debian/rules
diff options
context:
space:
mode:
authorAndrey Konovalov <andrey.konovalov@linaro.org>2013-05-05 02:40:36 +0400
committerAndrey Konovalov <andrey.konovalov@linaro.org>2013-05-05 02:40:36 +0400
commit314864b5a538c5ec1f871d814974edc37bdc676e (patch)
treef0d341e6eae1cd5c4ca6180aeb29a00e21ff8a8e /tools/gator/debian/rules
parente5f042c6edebec55bb20a5e399f892766ac65411 (diff)
parent8417d689429075fe59d92af4036e25424b13ea9c (diff)
Merge branch 'tracking-integration-linux-vexpress' into merge-linux-linaro-lsklsk-20130505.0
Diffstat (limited to 'tools/gator/debian/rules')
-rwxr-xr-xtools/gator/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/gator/debian/rules b/tools/gator/debian/rules
new file mode 100755
index 00000000000..c747748ff83
--- /dev/null
+++ b/tools/gator/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ CROSS_COMPILE ?= $(DEB_HOST_GNU_TYPE)-
+endif
+
+export CROSS_COMPILE
+
+export DH_OPTIONS
+
+%:
+ dh $@