aboutsummaryrefslogtreecommitdiff
path: root/tools/gator/debian/rules
diff options
context:
space:
mode:
authorJon Medhurst <tixy@linaro.org>2012-05-04 14:39:28 +0100
committerJon Medhurst <tixy@linaro.org>2012-05-16 17:35:59 +0100
commitb667e7b5ec5f6c772924dfcc0e6d1da8431f7d7d (patch)
tree266a887eb9f022ac2849ee523edc3a92f0479700 /tools/gator/debian/rules
parenta8e92ea7aa4978a2be43964ce31432ac5fb43929 (diff)
gator: ubuntu: Add packaginggator-5.10.0-0
Files and scripts for creating Debian packages for Gator and ARM DS-5 target. Signed-off-by: Jon Medhurst <tixy@linaro.org>
Diffstat (limited to 'tools/gator/debian/rules')
-rwxr-xr-xtools/gator/debian/rules15
1 files changed, 15 insertions, 0 deletions
diff --git a/tools/gator/debian/rules b/tools/gator/debian/rules
new file mode 100755
index 00000000000..c747748ff83
--- /dev/null
+++ b/tools/gator/debian/rules
@@ -0,0 +1,15 @@
+#!/usr/bin/make -f
+
+DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
+ CROSS_COMPILE ?= $(DEB_HOST_GNU_TYPE)-
+endif
+
+export CROSS_COMPILE
+
+export DH_OPTIONS
+
+%:
+ dh $@