aboutsummaryrefslogtreecommitdiff
path: root/openembedded-odp-rootfs.yaml
diff options
context:
space:
mode:
authorAnders Roxell <anders.roxell@linaro.org>2016-02-12 09:45:40 +0100
committerAnders Roxell <anders.roxell@linaro.org>2016-02-12 09:44:53 +0100
commit39eac028ea51a6bbe7a1335d86d99ce4691be947 (patch)
tree54a1cc4226502aa953af8172cff234b4eb2c1020 /openembedded-odp-rootfs.yaml
parente70031c054245f674334b89e8d93ac52c90fef9e (diff)
openembedded-odp-rootfs: cleanup since we trigger from trigger-build-odp
Change-Id: Ic6e2a5bc06ae82d445ebf9eb92a5e0d40ff70e3d Signed-off-by: Anders Roxell <anders.roxell@linaro.org>
Diffstat (limited to 'openembedded-odp-rootfs.yaml')
-rw-r--r--openembedded-odp-rootfs.yaml19
1 files changed, 5 insertions, 14 deletions
diff --git a/openembedded-odp-rootfs.yaml b/openembedded-odp-rootfs.yaml
index 0a62541fb5..fa5f7164a4 100644
--- a/openembedded-odp-rootfs.yaml
+++ b/openembedded-odp-rootfs.yaml
@@ -25,7 +25,7 @@
display-name: 'OpenEmbedded build for ODP'
scm:
- git:
- url: http://git.linaro.org/lng/odp.git
+ url: https://git.linaro.org/openembedded/jenkins-setup.git
refspec: +refs/heads/master:refs/remotes/origin/master
name: origin
branches:
@@ -64,13 +64,6 @@
export PATH="$HOME/bin:$PATH"
- git clone https://git.linaro.org/openembedded/jenkins-setup.git
-
- JENKINS_WORKSPACE=${WORKSPACE}/jenkins-setup
- # the post-build-* tools need to have the workspace pointing to jenkins-setup
- WORKSPACE=${JENKINS_WORKSPACE}
- cd ${WORKSPACE}
-
# we clean build and populate it from cache
bash -x pre-build-do-cleanup.sh
@@ -89,7 +82,6 @@
# Capture what we're building in the build output.
repo manifest -r
- WORKSPACE=$(dirname ${WORKSPACE})
cd ${WORKSPACE}
case "${arch}" in
@@ -109,7 +101,7 @@
KERNEL_URL="http://snapshots.linaro.org/kernel-hwpack/linux-linaro-lng-v4.1/${hwpack}/$(wget -q --no-check-certificate -O - https://ci.linaro.org/job/linux-lng-v4.1/hwpack=${hwpack},label=docker-utopic/lastSuccessfulBuild/buildNumber)"
DTB_URL=${KERNEL_URL}/dtbs
- export ROOTFS_BUILD_URL="http://snapshots.linaro.org/openembedded/images/odp-${arch}-gcc-${gcc_version}/${BUILD_NUMBER}/$(ls ${JENKINS_WORKSPACE}/out/linaro-image-lng-*.tar.gz |xargs basename)"
+ export ROOTFS_BUILD_URL="http://snapshots.linaro.org/openembedded/images/odp-${arch}-gcc-${gcc_version}/${BUILD_NUMBER}/$(ls ${WORKSPACE}/out/linaro-image-lng-*.tar.gz |xargs basename)"
STARTUP_NSH="${KERNEL_URL}/startup.nsh"
cat << EOF > post_build_lava_parameters
@@ -128,7 +120,6 @@
#!/bin/bash
set -ex
- JENKINS_WORKSPACE=${WORKSPACE}/jenkins-setup
template_file="template-base"
case "${arch}" in
@@ -141,19 +132,19 @@
export GIT_URL=$(grep "^SRC_URI =" jenkins-setup/meta-linaro/meta-linaro/recipes-extra/odp/odp_*.bb | cut -d'"' -f2 | cut -d';' -f1)
export GIT_COMMIT=$(grep "^SRCREV_odp =" jenkins-setup/meta-linaro/meta-linaro/recipes-extra/odp/odp_*.bb |cut -d'"' -f2 | cut -d'=' -f2)
- mkdir -p ${JENKINS_WORKSPACE}/out/lava
+ mkdir -p ${WORKSPACE}/out/lava
rm -rf configs lci-build-tools
git clone --depth 1 http://git.linaro.org/ci/lci-build-tools.git
git clone --depth 1 http://git.linaro.org/ci/job/configs.git
- ./lci-build-tools/yaml-to-json.py configs/odp/lava-job-definitions/${DEVICE_TYPE}/${template_file}.yaml > ${JENKINS_WORKSPACE}/out/lava/${template_file}.json
+ ./lci-build-tools/yaml-to-json.py configs/odp/lava-job-definitions/${DEVICE_TYPE}/${template_file}.yaml > ${WORKSPACE}/out/lava/${template_file}.json
# Publish to snapshots
test -d ${HOME}/bin || mkdir ${HOME}/bin
wget https://git.linaro.org/ci/publishing-api.git/blob_plain/HEAD:/linaro-cp.py -O ${HOME}/bin/linaro-cp.py
time python ${HOME}/bin/linaro-cp.py \
--api_version 3 \
- --link-latest ${JENKINS_WORKSPACE}/out openembedded/images/odp-${arch}-gcc-${gcc_version}/${BUILD_NUMBER}
+ --link-latest ${WORKSPACE}/out openembedded/images/odp-${arch}-gcc-${gcc_version}/${BUILD_NUMBER}
- inject:
properties-file: post_build_lava_parameters
- conditional-step: