summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/rules.real11
1 files changed, 11 insertions, 0 deletions
diff --git a/debian/rules.real b/debian/rules.real
index 403bfe0b8..2850e9847 100644
--- a/debian/rules.real
+++ b/debian/rules.real
@@ -261,6 +261,17 @@ install-headers_$(ARCH)_$(FEATURESET): $(STAMPS_DIR)/source_$(FEATURESET)
) \
| \
cpio -pd --preserve-modification-time '$(CURDIR)/$(DIR)'
+# arm64 headers references arch/arm
+ifneq ($(filter arm64,$(ARCH)),)
+ set -o pipefail; \
+ cd $(SOURCE_DIR); \
+ ( \
+ find arch/arm/include -name 'opcodes.h' -print; \
+ find $$(find arch/arm/include -name xen -type d -print) -print; \
+ ) \
+ | \
+ cpio -pd --preserve-modification-time '$(CURDIR)/$(DIR)'
+endif
dh_link /usr/lib/$(PACKAGE_NAME_KBUILD)/scripts $(BASE_DIR)/scripts