summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--debian/patches/debian/arch-sh4-fix-uimage-build.patch2
-rw-r--r--debian/patches/features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch18
2 files changed, 10 insertions, 10 deletions
diff --git a/debian/patches/debian/arch-sh4-fix-uimage-build.patch b/debian/patches/debian/arch-sh4-fix-uimage-build.patch
index 6fc5a08e8..911037d72 100644
--- a/debian/patches/debian/arch-sh4-fix-uimage-build.patch
+++ b/debian/patches/debian/arch-sh4-fix-uimage-build.patch
@@ -8,7 +8,7 @@ with a similar issue to powerpcspe-omit-uimage.patch]
--- a/arch/sh/Makefile
+++ b/arch/sh/Makefile
-@@ -75,7 +75,6 @@
+@@ -83,7 +83,6 @@ OBJCOPYFLAGS := -O binary -R .note -R .n
# Give the various platforms the opportunity to set default image types
defaultimage-$(CONFIG_SUPERH32) := zImage
diff --git a/debian/patches/features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch b/debian/patches/features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
index 194b2b7dc..356d04946 100644
--- a/debian/patches/features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
+++ b/debian/patches/features/all/Kbuild-kconfig-Verbose-version-of-listnewconfig.patch
@@ -13,14 +13,14 @@ maximilian attems <max@stro.at>. Simplified by Michal Marek
Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
---
scripts/kconfig/conf.c | 42 ++++++++++++++++++++++++++++++++----------
- scripts/kconfig/confdata.c | 9 +++++++++
+ scripts/kconfig/confdata.c | 13 ++++++++++++-
scripts/kconfig/expr.h | 2 ++
scripts/kconfig/lkc_proto.h | 1 +
- 4 files changed, 44 insertions(+), 10 deletions(-)
+ 4 files changed, 47 insertions(+), 11 deletions(-)
--- a/scripts/kconfig/conf.c
+++ b/scripts/kconfig/conf.c
-@@ -368,7 +368,6 @@ static void conf(struct menu *menu)
+@@ -369,7 +369,6 @@ static void conf(struct menu *menu)
switch (prop->type) {
case P_MENU:
if ((input_mode == silentoldconfig ||
@@ -28,7 +28,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
input_mode == olddefconfig) &&
rootEntry != menu) {
check_conf(menu);
-@@ -429,11 +428,7 @@ static void check_conf(struct menu *menu
+@@ -430,11 +429,7 @@ static void check_conf(struct menu *menu
if (sym && !sym_has_value(sym)) {
if (sym_is_changable(sym) ||
(sym_is_choice(sym) && sym_get_tristate_value(sym) == yes)) {
@@ -41,7 +41,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
if (!conf_cnt++)
printf(_("*\n* Restart config...\n*\n"));
rootEntry = menu_get_parent_menu(menu);
-@@ -446,6 +441,30 @@ static void check_conf(struct menu *menu
+@@ -447,6 +442,30 @@ static void check_conf(struct menu *menu
check_conf(child);
}
@@ -72,7 +72,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
static struct option long_opts[] = {
{"oldaskconfig", no_argument, NULL, oldaskconfig},
{"oldconfig", no_argument, NULL, oldconfig},
-@@ -493,6 +512,7 @@ int main(int ac, char **av)
+@@ -494,6 +513,7 @@ int main(int ac, char **av)
const char *progname = av[0];
int opt;
const char *name, *defconfig_file = NULL /* gcc uninit */;
@@ -80,7 +80,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
struct stat tmpstat;
setlocale(LC_ALL, "");
-@@ -672,16 +692,18 @@ int main(int ac, char **av)
+@@ -673,16 +693,18 @@ int main(int ac, char **av)
input_mode = silentoldconfig;
/* fall through */
case oldconfig:
@@ -120,7 +120,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
int conf_write(const char *name)
{
FILE *out;
-@@ -1170,7 +1178,10 @@ bool conf_set_all_new_symbols(enum conf_
+@@ -1171,7 +1179,10 @@ bool conf_set_all_new_symbols(enum conf_
bool has_changed = false;
for_all_symbols(i, sym) {
@@ -134,7 +134,7 @@ Signed-off-by: Ben Hutchings <ben@decadent.org.uk>
case S_BOOLEAN:
--- a/scripts/kconfig/expr.h
+++ b/scripts/kconfig/expr.h
-@@ -112,6 +112,8 @@ struct symbol {
+@@ -114,6 +114,8 @@ struct symbol {
/* Set symbol to y if allnoconfig; used for symbols that hide others */
#define SYMBOL_ALLNOCONFIG_Y 0x200000