summaryrefslogtreecommitdiff
path: root/debian/patches/debian/version.patch
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2014-09-13 06:23:27 +0000
committerBen Hutchings <benh@debian.org>2014-09-13 06:23:27 +0000
commitfc56a07b4e1cb98fbce0f19570fd2d521a6bdc56 (patch)
tree3724828c69ce4179b2e5d2574ab713e2423b8352 /debian/patches/debian/version.patch
parentcf68605af6e8158afec76050a29db28518b01e30 (diff)
Update to 3.17-rc4
- Drop and refresh various patches which are included in or conflict with upstream - Drop the patch restoring sm7xxfb, as no-one is maintaining it - Disable aufs temporarily svn path=/dists/trunk/linux/; revision=21840
Diffstat (limited to 'debian/patches/debian/version.patch')
-rw-r--r--debian/patches/debian/version.patch16
1 files changed, 8 insertions, 8 deletions
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index f8bb63774..c07b9aaeb 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -9,7 +9,7 @@ are set.
--- a/Makefile
+++ b/Makefile
-@@ -826,7 +826,7 @@ endif
+@@ -963,7 +963,7 @@ endif
prepare2: prepare3 outputmakefile asm-generic
prepare1: prepare2 $(version_h) include/generated/utsrelease.h \
@@ -18,7 +18,7 @@ are set.
$(cmd_crmodverdir)
archprepare: archheaders archscripts prepare1 scripts_basic
-@@ -858,12 +858,25 @@ define filechk_version.h
+@@ -995,12 +995,25 @@ define filechk_version.h
echo '#define KERNEL_VERSION(a,b,c) (((a) << 16) + ((b) << 8) + (c))';)
endef
@@ -54,7 +54,7 @@ are set.
#include <asm/current.h>
#include <asm/ptrace.h>
#include <asm/sysrq.h>
-@@ -16,8 +17,9 @@ void __show_regs(struct pt_regs *regs)
+@@ -16,8 +17,9 @@ void show_regs(struct pt_regs *regs)
{
printk("\n");
print_modules();
@@ -90,7 +90,7 @@ are set.
regs->ar_unat, regs->ar_pfs, regs->ar_rsc);
--- a/arch/powerpc/kernel/process.c
+++ b/arch/powerpc/kernel/process.c
-@@ -38,6 +38,7 @@
+@@ -37,6 +37,7 @@
#include <linux/personality.h>
#include <linux/random.h>
#include <linux/hw_breakpoint.h>
@@ -98,7 +98,7 @@ are set.
#include <asm/pgtable.h>
#include <asm/uaccess.h>
-@@ -843,8 +844,9 @@ void show_regs(struct pt_regs * regs)
+@@ -1004,8 +1005,9 @@ void show_regs(struct pt_regs * regs)
printk("NIP: "REG" LR: "REG" CTR: "REG"\n",
regs->nip, regs->link, regs->ctr);
@@ -112,15 +112,15 @@ are set.
printk(" CR: %08lx XER: %08lx\n", regs->ccr, regs->xer);
--- a/kernel/printk/printk.c
+++ b/kernel/printk/printk.c
-@@ -45,6 +45,7 @@
- #include <linux/poll.h>
+@@ -46,6 +46,7 @@
#include <linux/irq_work.h>
#include <linux/utsname.h>
+ #include <linux/ctype.h>
+#include <generated/package.h>
#include <asm/uaccess.h>
-@@ -2871,11 +2872,12 @@ void __init dump_stack_set_arch_desc(con
+@@ -3034,11 +3035,12 @@ void __init dump_stack_set_arch_desc(con
*/
void dump_stack_print_info(const char *log_lvl)
{