summaryrefslogtreecommitdiff
path: root/debian/patches/debian/version.patch
diff options
context:
space:
mode:
authorBastian Blank <waldi@debian.org>2007-01-08 18:19:26 +0000
committerBastian Blank <waldi@debian.org>2007-01-08 18:19:26 +0000
commite9ed91708589e39db259e3d3385ddba39d240a1b (patch)
tree09792c40e44862fcd147f1f8367a61daa7e0deb9 /debian/patches/debian/version.patch
parent0c8c083cc01c03e1f292ca5f7e66d11d02784e1f (diff)
* debian/changelog: Set version to 2.6.20~rc4-1~experimental.1.
* debian/patches/debian/version.patch: Update. * debian/patches/series/1~experimental.1 - Remove backport patches. - Disable non-working patches. svn path=/dists/trunk/linux-2.6/; revision=8140
Diffstat (limited to 'debian/patches/debian/version.patch')
-rw-r--r--debian/patches/debian/version.patch58
1 files changed, 41 insertions, 17 deletions
diff --git a/debian/patches/debian/version.patch b/debian/patches/debian/version.patch
index d265ec2eb..f062358fd 100644
--- a/debian/patches/debian/version.patch
+++ b/debian/patches/debian/version.patch
@@ -1,30 +1,54 @@
-diff --git a/init/version.c b/init/version.c
-index 3ddc3ce..c2111a7 100644
---- a/init/version.c
-+++ b/init/version.c
-@@ -29,5 +29,15 @@ struct new_utsname system_utsname = {
- EXPORT_SYMBOL(system_utsname);
+diff --git a/fs/proc/proc_misc.c b/fs/proc/proc_misc.c
+index 92ea774..bbab264 100644
+--- a/fs/proc/proc_misc.c
++++ b/fs/proc/proc_misc.c
+@@ -254,10 +254,18 @@ static int version_read_proc(char *page, char **start, off_t off,
+ {
+ int len;
- const char linux_banner[] =
-- "Linux version " UTS_RELEASE " (" LINUX_COMPILE_BY "@"
-- LINUX_COMPILE_HOST ") (" LINUX_COMPILER ") " UTS_VERSION "\n";
-+ "Linux version " UTS_RELEASE " "
+- /* FIXED STRING! Don't touch! */
+ len = snprintf(page, PAGE_SIZE,
+ "%s version %s"
+#ifdef LINUX_COMPILE_SYSTEM_OFFICIAL
-+ "(" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
-+ LINUX_COMPILE_SYSTEM_VERSION ") "
-+ "(" LINUX_COMPILE_SYSTEM_MAINTAINER ") "
++ " (" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
++ LINUX_COMPILE_SYSTEM_VERSION ")"
++ " (" LINUX_COMPILE_SYSTEM_MAINTAINER ")"
+#else
+# ifdef LINUX_COMPILE_SYSTEM_VERSION
-+ "(" LINUX_COMPILE_SYSTEM_VERSION ") "
++ " (" LINUX_COMPILE_SYSTEM_VERSION ")"
+# endif
-+ "(" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ") "
+ " (" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ")"
+#endif
-+ "(" LINUX_COMPILER ") " UTS_VERSION "\n";
+ " (" LINUX_COMPILER ")"
+ " %s\n",
+ utsname()->sysname,
+diff --git a/init/main.c b/init/main.c
+index 2b1cdaa..f860297 100644
+--- a/init/main.c
++++ b/init/main.c
+@@ -484,7 +484,16 @@ void __init __attribute__((weak)) smp_setup_processor_id(void)
+
+ static const char linux_banner[] =
+ "Linux version " UTS_RELEASE
++#ifdef LINUX_COMPILE_SYSTEM_OFFICIAL
++ " (" LINUX_COMPILE_SYSTEM_DISTRIBUTION " "
++ LINUX_COMPILE_SYSTEM_VERSION ")"
++ " (" LINUX_COMPILE_SYSTEM_MAINTAINER ")"
++#else
++# ifdef LINUX_COMPILE_SYSTEM_VERSION
++ " (" LINUX_COMPILE_SYSTEM_VERSION ")"
++# endif
+ " (" LINUX_COMPILE_BY "@" LINUX_COMPILE_HOST ")"
++#endif
+ " (" LINUX_COMPILER ")"
+ " " UTS_VERSION "\n";
+
+diff --git a/init/version.c b/init/version.c
diff --git a/scripts/mkcompile_h b/scripts/mkcompile_h
index d7b8a38..87035a0 100755
--- a/scripts/mkcompile_h
+++ b/scripts/mkcompile_h
-@@ -46,16 +46,34 @@ ( echo /\* This file is auto generated,
+@@ -46,16 +46,34 @@ UTS_TRUNCATE="sed -e s/\(.\{1,$UTS_LEN\}\).*/\1/"
echo \#define UTS_VERSION \"`echo $UTS_VERSION | $UTS_TRUNCATE`\"