summaryrefslogtreecommitdiff
path: root/debian/patches/debian/dfsg
diff options
context:
space:
mode:
authorBen Hutchings <benh@debian.org>2012-06-02 20:21:18 +0000
committerBen Hutchings <benh@debian.org>2012-06-02 20:21:18 +0000
commit07300ab0efa653bdd2b8cfbc8496d0a0db1ec85f (patch)
treeb306c20ba0a1ea82daf2f24d237410d5ddaaa598 /debian/patches/debian/dfsg
parent1c3a69f3081dd10e39342e895423e66e776982bb (diff)
DFSG: video: Remove nvidiafb and rivafb (Closes: #383481)
These drivers include apparently obfuscated code. The nouveau driver supports all the same hardware, aside from RIVA 128 (NV3). svn path=/dists/sid/linux-2.6/; revision=19057
Diffstat (limited to 'debian/patches/debian/dfsg')
-rw-r--r--debian/patches/debian/dfsg/files-14
-rw-r--r--debian/patches/debian/dfsg/video-remove-nvidiafb-and-rivafb.patch137
2 files changed, 141 insertions, 0 deletions
diff --git a/debian/patches/debian/dfsg/files-1 b/debian/patches/debian/dfsg/files-1
index c8b9dbd3e..2b0e90ff9 100644
--- a/debian/patches/debian/dfsg/files-1
+++ b/debian/patches/debian/dfsg/files-1
@@ -23,5 +23,9 @@ unifdef drivers/staging/rtl8192e/r8192E_hwimg.c -UREMOVE_DFSG
rm drivers/staging/wlags49_h2/ap_*.c
rm drivers/staging/wlags49_h2/sta_*.c
+# These include apparently obfuscated code
+rm drivers/video/nvidia/
+rm drivers/video/riva/
+
rm sound/pci/cs46xx/cs46xx_image.h
rm sound/pci/cs46xx/imgs
diff --git a/debian/patches/debian/dfsg/video-remove-nvidiafb-and-rivafb.patch b/debian/patches/debian/dfsg/video-remove-nvidiafb-and-rivafb.patch
new file mode 100644
index 000000000..e9abe4768
--- /dev/null
+++ b/debian/patches/debian/dfsg/video-remove-nvidiafb-and-rivafb.patch
@@ -0,0 +1,137 @@
+From: Ben Hutchings <ben@decadent.org.uk>
+Date: Sat, 2 Jun 2012 19:53:38 +0100
+Subject: video: Remove nvidiafb and rivafb
+Bug-Debian: http://bugs.debian.org/383481
+
+These drivers contain register programming code provided by the
+hardware vendor that appears to have been deliberately obfuscated.
+This is arguably not the preferred form for modification.
+
+These drivers are also largely redundant with nouveau. The RIVA 128
+(NV3) is not supported by nouveau but is about 15 years old and
+probably discontinued 10 years ago.
+
+---
+ drivers/video/Kconfig | 95 ------------------------------------------------
+ drivers/video/Makefile | 2 -
+ 2 files changed, 97 deletions(-)
+
+diff --git a/drivers/video/Kconfig b/drivers/video/Kconfig
+index d83e967..fe92039 100644
+--- a/drivers/video/Kconfig
++++ b/drivers/video/Kconfig
+@@ -1028,101 +1028,6 @@ config FB_ATMEL_STN
+
+ If unsure, say N.
+
+-config FB_NVIDIA
+- tristate "nVidia Framebuffer Support"
+- depends on FB && PCI
+- select FB_BACKLIGHT if FB_NVIDIA_BACKLIGHT
+- select FB_MODE_HELPERS
+- select FB_CFB_FILLRECT
+- select FB_CFB_COPYAREA
+- select FB_CFB_IMAGEBLIT
+- select BITREVERSE
+- select VGASTATE
+- help
+- This driver supports graphics boards with the nVidia chips, TNT
+- and newer. For very old chipsets, such as the RIVA128, then use
+- the rivafb.
+- Say Y if you have such a graphics board.
+-
+- To compile this driver as a module, choose M here: the
+- module will be called nvidiafb.
+-
+-config FB_NVIDIA_I2C
+- bool "Enable DDC Support"
+- depends on FB_NVIDIA
+- select FB_DDC
+- help
+- This enables I2C support for nVidia Chipsets. This is used
+- only for getting EDID information from the attached display
+- allowing for robust video mode handling and switching.
+-
+- Because fbdev-2.6 requires that drivers must be able to
+- independently validate video mode parameters, you should say Y
+- here.
+-
+-config FB_NVIDIA_DEBUG
+- bool "Lots of debug output"
+- depends on FB_NVIDIA
+- default n
+- help
+- Say Y here if you want the nVidia driver to output all sorts
+- of debugging information to provide to the maintainer when
+- something goes wrong.
+-
+-config FB_NVIDIA_BACKLIGHT
+- bool "Support for backlight control"
+- depends on FB_NVIDIA
+- default y
+- help
+- Say Y here if you want to control the backlight of your display.
+-
+-config FB_RIVA
+- tristate "nVidia Riva support"
+- depends on FB && PCI
+- select FB_BACKLIGHT if FB_RIVA_BACKLIGHT
+- select FB_MODE_HELPERS
+- select FB_CFB_FILLRECT
+- select FB_CFB_COPYAREA
+- select FB_CFB_IMAGEBLIT
+- select BITREVERSE
+- select VGASTATE
+- help
+- This driver supports graphics boards with the nVidia Riva/Geforce
+- chips.
+- Say Y if you have such a graphics board.
+-
+- To compile this driver as a module, choose M here: the
+- module will be called rivafb.
+-
+-config FB_RIVA_I2C
+- bool "Enable DDC Support"
+- depends on FB_RIVA
+- select FB_DDC
+- help
+- This enables I2C support for nVidia Chipsets. This is used
+- only for getting EDID information from the attached display
+- allowing for robust video mode handling and switching.
+-
+- Because fbdev-2.6 requires that drivers must be able to
+- independently validate video mode parameters, you should say Y
+- here.
+-
+-config FB_RIVA_DEBUG
+- bool "Lots of debug output"
+- depends on FB_RIVA
+- default n
+- help
+- Say Y here if you want the Riva driver to output all sorts
+- of debugging information to provide to the maintainer when
+- something goes wrong.
+-
+-config FB_RIVA_BACKLIGHT
+- bool "Support for backlight control"
+- depends on FB_RIVA
+- default y
+- help
+- Say Y here if you want to control the backlight of your display.
+-
+ config FB_I810
+ tristate "Intel 810/815 support (EXPERIMENTAL)"
+ depends on EXPERIMENTAL && FB && PCI && X86_32 && AGP_INTEL
+diff --git a/drivers/video/Makefile b/drivers/video/Makefile
+index 9b9d8ff..4361446 100644
+--- a/drivers/video/Makefile
++++ b/drivers/video/Makefile
+@@ -38,8 +38,6 @@ obj-$(CONFIG_FB_PM2) += pm2fb.o
+ obj-$(CONFIG_FB_PM3) += pm3fb.o
+
+ obj-$(CONFIG_FB_MATROX) += matrox/
+-obj-$(CONFIG_FB_RIVA) += riva/
+-obj-$(CONFIG_FB_NVIDIA) += nvidia/
+ obj-$(CONFIG_FB_ATY) += aty/ macmodes.o
+ obj-$(CONFIG_FB_ATY128) += aty/ macmodes.o
+ obj-$(CONFIG_FB_RADEON) += aty/