summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Hutchings <ben@decadent.org.uk>2015-11-26 20:47:26 +0000
committerBen Hutchings <ben@decadent.org.uk>2015-12-04 01:18:53 +0000
commitb1805eb5b3ae3be5fa0ea928b0a2fb16258f692c (patch)
tree698547aa7f515335f437d398ad7ab714e93f0606
parent37aa7dc44d7cbfbd40a7b863b113ac1d49e44aaa (diff)
[x86] drm/i915: shut up gen8+ SDE irq dmesg noise (Closes: #806304)
(cherry picked from commit fd13855f777dea69cac3ae5314bc20c73e1bc2af)
-rw-r--r--debian/changelog1
-rw-r--r--debian/patches/bugfix/x86/drm-i915-shut-up-gen8-sde-irq-dmesg-noise.patch66
-rw-r--r--debian/patches/series1
3 files changed, 68 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
index 2a550c818..f28910fd3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -32,6 +32,7 @@ linux (4.2.6-2) UNRELEASED; urgency=medium
* [armhf] udeb: Add stmmac platform modules dwmac-generic, dwmac-socfpga
and dwmac-sunxi to nic-modules (Closes: #805098)
* wireless: Enable WL_MEDIATEK, MT7601U as module
+ * [x86] drm/i915: shut up gen8+ SDE irq dmesg noise (Closes: #806304)
-- Salvatore Bonaccorso <carnil@debian.org> Tue, 10 Nov 2015 22:05:58 +0100
diff --git a/debian/patches/bugfix/x86/drm-i915-shut-up-gen8-sde-irq-dmesg-noise.patch b/debian/patches/bugfix/x86/drm-i915-shut-up-gen8-sde-irq-dmesg-noise.patch
new file mode 100644
index 000000000..fa97fb358
--- /dev/null
+++ b/debian/patches/bugfix/x86/drm-i915-shut-up-gen8-sde-irq-dmesg-noise.patch
@@ -0,0 +1,66 @@
+From: Daniel Vetter <daniel.vetter@ffwll.ch>
+Date: Fri, 23 Oct 2015 10:56:12 +0200
+Subject: drm/i915: shut up gen8+ SDE irq dmesg noise
+Origin: http://cgit.freedesktop.org/drm-intel/commit?id=97e5ed1111dcc5300a0f59a55248cd243937a8ab
+
+We get tons of cases where the master interrupt handler apparently set
+a bit, with the SDEIIR disagreeing. No idea what's going on there, but
+it's consistent on gen8+, no one seems to care about it and it's
+making CI results flaky.
+
+Shut it up.
+
+No idea what's going on here, but we've had fun with PCH interrupts
+before:
+
+commit 44498aea293b37af1d463acd9658cdce1ecdf427
+Author: Paulo Zanoni <paulo.r.zanoni@intel.com>
+Date: Fri Feb 22 17:05:28 2013 -0300
+
+ drm/i915: also disable south interrupts when handling them
+
+Note that there's a regression report in Bugzilla, and other
+regression reports on the mailing lists keep croping up. But no ill
+effects have ever been reported. But for paranoia still keep the
+message at a debug level as a breadcrumb, just in case.
+
+This message was introduced in
+
+commit 38cc46d73ed99dd7002f1406002e52d7975d16cc
+Author: Oscar Mateo <oscar.mateo@intel.com>
+Date: Mon Jun 16 16:10:59 2014 +0100
+
+ drm/i915/bdw: Ack interrupts before handling them (GEN8)
+
+v2: Improve commit message a bit.
+
+Cc: Paulo Zanoni <paulo.r.zanoni@intel.com>
+Signed-off-by: Daniel Vetter <daniel.vetter@intel.com>
+Link: http://patchwork.freedesktop.org/patch/msgid/1445590572-23631-2-git-send-email-daniel.vetter@ffwll.ch
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=92084
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=80896
+Acked-by: Mika Kuoppala <mika.kuoppala@intel.com>
+Signed-off-by: Daniel Vetter <daniel.vetter@ffwll.ch>
+---
+ drivers/gpu/drm/i915/i915_irq.c | 10 +++++++---
+ 1 file changed, 7 insertions(+), 3 deletions(-)
+
+--- a/drivers/gpu/drm/i915/i915_irq.c
++++ b/drivers/gpu/drm/i915/i915_irq.c
+@@ -2168,9 +2168,13 @@ static irqreturn_t gen8_irq_handler(int
+ I915_WRITE(SDEIIR, pch_iir);
+ ret = IRQ_HANDLED;
+ cpt_irq_handler(dev, pch_iir);
+- } else
+- DRM_ERROR("The master control interrupt lied (SDE)!\n");
+-
++ } else {
++ /*
++ * Like on previous PCH there seems to be something
++ * fishy going on with forwarding PCH interrupts.
++ */
++ DRM_DEBUG_DRIVER("The master control interrupt lied (SDE)!\n");
++ }
+ }
+
+ I915_WRITE_FW(GEN8_MASTER_IRQ, GEN8_MASTER_IRQ_CONTROL);
diff --git a/debian/patches/series b/debian/patches/series
index 4aa544cbe..fc9db3bf3 100644
--- a/debian/patches/series
+++ b/debian/patches/series
@@ -115,3 +115,4 @@ bugfix/all/unix-avoid-use-after-free-in-ep_remove_wait_queue.patch
bugfix/all/isdn_ppp-add-checks-for-allocation-failure-in-isdn_p.patch
bugfix/all/ppp-slip-validate-vj-compression-slot-parameters-com.patch
bugfix/all/btrfs-fix-truncation-of-compressed-and-inlined-exten.patch
+bugfix/x86/drm-i915-shut-up-gen8-sde-irq-dmesg-noise.patch