aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog9
-rw-r--r--debian/control9
-rw-r--r--debian/platform-and-targets5
-rwxr-xr-xdebian/rules26
4 files changed, 30 insertions, 19 deletions
diff --git a/debian/changelog b/debian/changelog
index cf3254560..a0c3f5997 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,12 @@
+u-boot-linaro (2010.09~rc1.1-0ubuntu4) natty; urgency=low
+
+ * Add Gumstix Overo, omap3_overo.
+ * Cleanup rules.
+ * Fix clean to remove some files which upstream creates in the source tree.
+ * List platform and targets in debian/platform-and-targets.
+
+ -- Loïc Minier <loic.minier@linaro.org> Fri, 03 Dec 2010 15:44:02 +0100
+
u-boot-linaro (2010.09~rc1.1-0ubuntu3) maverick; urgency=low
[ Steve Sakoman ]
diff --git a/debian/control b/debian/control
index 6b9195d18..08a5c24f2 100644
--- a/debian/control
+++ b/debian/control
@@ -16,6 +16,15 @@ Description: U-Boot bootloader binary for various TI OMAP3 Beagle boards
contains the u-boot binary blob, and is not usually needed on a normal
system
+Package: u-boot-linaro-omap3-overo
+Architecture: armel
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: U-Boot bootloader binary for Gumstix Overo boards
+ This package contains the U-Boot bootloader which is responsible for
+ loading and executing the Linux kernel on those boards. This package
+ contains the u-boot binary blob, and is not usually needed on a normal
+ system
+
Package: u-boot-linaro-omap4-panda
Architecture: armel
Depends: ${shlibs:Depends}, ${misc:Depends}
diff --git a/debian/platform-and-targets b/debian/platform-and-targets
new file mode 100644
index 000000000..de7710e62
--- /dev/null
+++ b/debian/platform-and-targets
@@ -0,0 +1,5 @@
+ca9x4_ct_vxp u-boot.bin ca9x4-ct-vxp
+mx51evk u-boot.imx mx51evk
+omap3_beagle u-boot.bin omap3-beagle
+omap3_overo u-boot.bin omap3-overo
+omap4_panda u-boot.bin omap4-panda
diff --git a/debian/rules b/debian/rules
index b3b5d7d01..be9f57293 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,39 +12,27 @@ DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
export CROSS_COMPILE=$(DEB_HOST_GNU_TYPE)-
endif
-#export DH_VERBOSE=1
-#export DH_OPTIONS=-v
-
-PLATFORMS_AND_TARGETS= \
- ca9x4_ct_vxp u-boot.bin ca9x4-ct-vxp\
- mx51evk u-boot.imx mx51evk\
- omap3_beagle u-boot.bin omap3-beagle\
- omap4_panda u-boot.bin omap4-panda
%:
dh $@
-override_dh_auto_configure:
- @
-
override_dh_auto_clean:
- $(MAKE) distclean
+ # upstream only cleans these files if passing the right O=, but it
+ # shouldn't create these the source tree in the first place
+ # XXX this hardcodes "arm"
+ rm -f arch/arm/include/asm/arch arch/arm/include/asm/proc
rm -rf debian/build
-# the u-boot.imx target does not work with O= and make mrproper
-# removes all *.bin files in the tree so we use rsync to make
-# a copy of the tree for each platform
override_dh_auto_build:
- echo $(PLATFORMS_AND_TARGETS)| xargs -n 3 | \
while read plat target deb; do \
mkdir -p debian/build/$$plat; \
$(MAKE) O=$$PWD/debian/build/$$plat $${plat}_config; \
find debian/build; \
$(MAKE) O=$$PWD/debian/build/$$plat; \
- done
+ done <debian/platform-and-targets
override_dh_auto_install:
- echo $(PLATFORMS_AND_TARGETS) | xargs -n 3 | \
while read plat target deb; do \
install -D -m644 debian/build/$$plat/$$target debian/u-boot-linaro-$$deb/usr/lib/u-boot/$$plat/$$target; \
- done
+ done <debian/platform-and-targets
+