aboutsummaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorTim Gardner <tim.gardner@canonical.com>2011-08-22 10:43:08 -0600
committerJohn Rigby <john.rigby@linaro.org>2011-09-23 08:56:54 -0600
commita2351fa07f494c5e7dd06c35fb29eca477e02c5b (patch)
tree4196113ae0ac1e069aad96cd9babc99ca17fc802 /debian
parentcd73132fd7ee84116db586aec8bbba8733316fd2 (diff)
UBUNTU: [Config] Linearize and simplify tree preparation rules
Signed-off-by: Tim Gardner <tim.gardner@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/rules.d/2-binary-arch.mk6
-rw-r--r--debian/rules.d/4-checks.mk2
2 files changed, 2 insertions, 6 deletions
diff --git a/debian/rules.d/2-binary-arch.mk b/debian/rules.d/2-binary-arch.mk
index 06b24a24ac4..8f6c5a862f3 100644
--- a/debian/rules.d/2-binary-arch.mk
+++ b/debian/rules.d/2-binary-arch.mk
@@ -10,9 +10,7 @@ build_cd =
build_O = O=$(builddir)/build-$*
endif
-prepare-%: $(stampdir)/stamp-prepare-%
- @# Empty for make to be happy
-$(stampdir)/stamp-prepare-%: $(stampdir)/stamp-prepare-tree-% prepare-checks-%
+$(stampdir)/stamp-prepare-%: config-prepare-check-%
@touch $@
$(stampdir)/stamp-prepare-tree-%: target_flavour = $*
$(stampdir)/stamp-prepare-tree-%: $(commonconfdir)/config.common.$(family) $(archconfdir)/config.common.$(arch) $(archconfdir)/config.flavour.%
@@ -30,7 +28,7 @@ $(stampdir)/stamp-prepare-tree-%: $(commonconfdir)/config.common.$(family) $(arc
build-%: $(stampdir)/stamp-build-%
@# Empty for make to be happy
$(stampdir)/stamp-build-%: target_flavour = $*
-$(stampdir)/stamp-build-%: prepare-%
+$(stampdir)/stamp-build-%: $(stampdir)/stamp-prepare-%
@echo "Building $*..."
$(build_cd) $(kmake) $(build_O) $(conc_level) $(build_image)
$(build_cd) $(kmake) $(build_O) $(conc_level) modules
diff --git a/debian/rules.d/4-checks.mk b/debian/rules.d/4-checks.mk
index d1c0ad96683..cc953b7b7b4 100644
--- a/debian/rules.d/4-checks.mk
+++ b/debian/rules.d/4-checks.mk
@@ -26,5 +26,3 @@ config-prepare-check-%: $(stampdir)/stamp-prepare-tree-%
@perl -f $(DROOT)/scripts/config-check \
$(builddir)/build-$*/.config "$(arch)" "$*" "$(sharedconfdir)" "$(skipconfig)"
-prepare-checks-%: config-prepare-check-%
- @# Will be calling more stuff later